forum header v1

normal Strange after-touch and velocity behaviour

More
1 year 6 months ago - 1 year 6 months ago #1 by norlee
norlee created the topic: Strange after-touch and velocity behaviour
Hi,

New to this forum so hello to all.

My XTk seems to be having a bit of a problem. I first noticed this when recording midi tracks - I would get all sorts of odd notes showing in the recording track that I wasn't actually playing (coincident with keyboard pressure and velocity info). On playback it would screech and make a terrible sound (quite apart from my playing) and cause the keyboard to hang I would have to do the panic button thing to get it under control.

It seems from looking at the midi stream in midi-ox that even the slightest pressure/hard key press generates masses of channel after-touch and pitch-bend info.

I have initialised a program to get all options flat/zero but still it happily sends pitch-bend and after-touch if anything more than delicate pressure is applied.

I have reloaded the factory sounds as well and repeated the initialise program routine, again without success.

Has anyone seen this before or better still any advice on how to fix?

XTk is V2.33

I have also included a picture of a recorded track and a sample from midi-ox.

Many thanks,

norman
Attachments:
Last Edit: 1 year 6 months ago by norlee.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #2 by Qwave
Qwave replied the topic: Strange after-touch and velocity behaviour
Sorry, but this is the well known XTk aftertouch bug.

There was no version of firmware for the XTk without this problem.
Use some MIDI filter if you wand to use the MIDI output stream.
But beware, this might not solve the problem, as there are also some not well formed MIDI messages at the output causing all kinds of strange things to receiving MIDI synths and software.

But there is no problem with this when using the keyboard to control the XTk itself.

I love my XTk for its sound and features.
The following user(s) said Thank You: norlee

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #3 by norlee
norlee replied the topic: Strange after-touch and velocity behaviour
Many thanks for your reply, amazing the right combination of keywords does indeed throw up lots of results, silly me.

Thanks again.

Please Log in or Create an account to join the conversation.

More
8 months 1 day ago #4 by aisaak
aisaak replied the topic: Strange after-touch and velocity behaviour - Problems with Waldorf Support!
Hi, interesting thread.

I have a different problem with my XTk - Waldorf simply won't return it after attempting a repair.
This is very disconcerting as it has been almost a year since sending it in. The communication has been absolutely horrible,
and the support team keeps coming up with new excuses - one more unlikely than the next, after initially confusing it with another XTk without knobs,
then an XT, etc.

Does anyone know what is going on at Waldorf Support?

I love this company's products and have several of them, after going through SAE but this is just ridiculous!!

Thanks in advance.

Please Log in or Create an account to join the conversation.

Moderators: Pablo