Notes stuck when trying to record automation in Ableton Live 10

More
4 months 4 weeks ago #1 by dask
I am having an issue were randomly notes become stuck on if I try to record cc automation in live 10. I am using the external instrument device in session view. I can record the midi notes and play back. But if I want to then record some automation of the knobs over the top of the midi, at some random point the notes get stuck.

Using Firmware 1.27

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #2 by Qwave
Sounds like a MIDI loop.

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #3 by dask
I am using the the STVC as my main midi controller also. The same issue happens if I don't use the external instrument device in ableton but instead have a midi and audio track. I can work around it. The online manual for the stvc does not explain some of the settings options.

In the settings I have TX Edits, TX Program Change, TX aftertough, TX keys / controls, local control, Control X and Device ID.

I understand some of these but no idea what Control X is. It is set to 000.
My understanding
TX keys / controls = transmit key presses and knob movement.
TX program change = transmit changing of the patch.
TX Edits = ?
Control X = ?
Should local control be off ?

I will have a play about.

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago - 4 months 4 weeks ago #4 by Qwave
You can assign the Control X modulation to a MIDI CC number and use it in the modulation matrix. I don't think this has something to do with your problem.

But you should for sure set the LOCAL CONTROL to OFF when using the STVC as a master keyboard with a DAW and the DAW sending back the received notes to the STVC. Not doing so is the main reason for MIDI loops for all synths. This is why there is a mode called LOCAL CONTROL on most synths and keyboards.

But remember this (STVC manual page #27):

The OFF setting is only valid until the STVC is switched off. Hint: Hold Tweak and the NO button while switching on the STVC sets LOCAL CONTROL to OFF.


TX keys / controls /aftertouch /edits / program change should be set to ON to record this data in the DAW or to use these to play other MIDI equipment.
Last edit: 4 months 4 weeks ago by Qwave. Reason: typo

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #5 by dask
Thankyou for your help.

Shame that it would not save the local control setting like the other options.

One stange thing I did notice whilst experimenting is if I set the midi channel to say 1 it responds on 1 and 2 but not 3-16. If I say set it to 3 for example it responds on 3 and 4. Always the channel set and the next one up. I just leave it on omni since I only have 1 hardware synth connected at a time for now as I also use software instruments.

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #6 by Qwave
It uses one MIDI channel for the strings and the other for the polysynth. So if you set the Layer switch for split, you get strings on the set MIDI channel and the polysynth on the other (if I remember it right).
The following user(s) said Thank You: dask

Please Log in or Create an account to join the conversation.