Bugs in OS1.14

More
5 years 6 months ago #7 by flake02
Replied by flake02 on topic Bugs in OS1.14
OSC 1 & 2 set Level to 0
OSC 3 as FB set Level to max

Sometimes generates an high pitch sound and sometimes not. regardless the cut off/resonance/filter type.

Only when drive curve is activate or deactivate, the fb appears.

So.. There are many patches that uses Feedback. They always do not sound the same.
Which is the normal behavior of FB?

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #8 by flake02
Replied by flake02 on topic Bugs in OS1.14
ALT arpeggiator mode seems to be UP&DOWN in the input order
#UP and #DOWN seems to be UP and DOWN in pitch order

#ALT (in my pulse 2) plays the line and repeat the highest notes indefinitely.
I think it is a bug

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #9 by flake02
Replied by flake02 on topic Bugs in OS1.14
I have a question.
HP filter open wide cover all frequencies like LP24? Mine eats very low frequencies (i think this could be normal)

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #10 by flake02
Replied by flake02 on topic Bugs in OS1.14
Filter tune have not complete accuracy.
When cutoff: 54 , res: 127
Play c2,c5,c6,c5,c2,c5,c6,... note that c5 pitch is always different.
ps: keytrack +32
Last edit: 5 years 6 months ago by flake02.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #11 by msepsis
Replied by msepsis on topic Bugs in OS1.14
Strange behavior with how incoming bank select and program change messages are interpreted by the pulse 2.
The issue persists no matter whether the incoming messages are sent via USB MIDI or the 5 pin DIN.

Here’s precisely what I’m sending to the Pulse 2 and what the result is.

[b0 00 00] <—bank select to bank 1
[c0 00] <————programChange to prg 1
———————————————————————————pulse 2 is now at “001”
[b0 00 01]<—-bank select to bank 2
[c0 01] <————programChange to prg 2
———————————————————————————pulse 2 is now at “102”
[c0 02] <————programChange to prg 3
———————————————————————————pulse 2 is now at “003”

According to the MMA who writes the MIDI spec this is not right.
I should not have to send another bank select to stay within the previously selected bank.
Going up a program while in bank 2 should set the pulse 2 to program 103, not program 003! :S

cross-platform software editors for Waldorf synths
www.monstrummedia.com
Last edit: 5 years 6 months ago by msepsis.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #12 by msepsis
Replied by msepsis on topic Bugs in OS1.14
The SYSEX documentation is not updated - there are more Mod Matrix Destinations now:
M-ACCU
M-PRODUCT
M-DELAY
M-SMOOTH
M-MIN
M-MAX
VCF ENV AMT


Additionally the program categories seem to have been truncated from previous versions which included:
NONE =0
ARP =1
ATMO=2
BASS=3
DRUM=4
FX=5
KEYS=6
LEAD=7
MONO=8
PAD=9
PERC=10
POLY=11
SEQ=12
DUB=13
LUSHY=14
STRING=15
PLUCK=16
WIND=17
NOISE=18
INPUT FX=19
INIT=20


Those italicized are no longer available in 1.14.

cross-platform software editors for Waldorf synths
www.monstrummedia.com

Please Log in or Create an account to join the conversation.

Moderators: Pablo