Heavy Noises with the Iridium, while using Midi via Din and USB

More
4 months 16 hours ago #1 by flexxmexx
Hi guys.

got heavy issues with my new Iridium.
While im using Midi I got lot of noise problems 
trough my sound card. 

any Solutions?

 

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago - 3 months 4 weeks ago #2 by daniel_sneed
Maybe try an usb isolator.
I had such cases with my Novation synths.
Solved with a KETEREX usb isolator. Not that cheap, but worthy.
Last edit: 3 months 4 weeks ago by daniel_sneed.
The following user(s) said Thank You: flexxmexx

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #3 by .ando
Soon after getting my Iridium, I noticed noise when connected via USB to computer. The cable I was using was an ordinary one which had caused no problems when used with USB interface. Switching to a cable with one of those (ferrite?) bulbs on it solved the problem.
The following user(s) said Thank You: flexxmexx

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #4 by flexxmexx
ok thx..

maybe I will try this..

I don't understand. why my iridium making noises even when I go straight to my interface or sampler.

i here this when I push the volume to the max.

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #5 by flexxmexx
its still the same. even when I change cables. :(

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #6 by mkinne28
I am also getting some noise from my Iridium, which I have had for less than a month. 
I get a popping noise at the end of every signal/note played. Just one popping sound. When I listen through headphone directly from the iridium I don't hear it, but when I connect to a mixer via 1/4 inch cable it always happens, and Ive tried this on multiple mixers. Infuriating. Any ideas?

Thanks. 

Please Log in or Create an account to join the conversation.