Recalling Multi patches with midi

More
2 months 4 days ago #1 by Burrboe
Hi everyone.  I'm trying to recall different multi's using an FC1 foot controller.  Its a midi guitar controller that has its own patches.  So I want to be able to assign patches in the FC1 to multi patches. So, as an example,  when I press the FC1 to change from its patch 1 to patch 2, I want the blofeld to switch from multi 1 to multi 2. The FC1 patches can each be set to make a program change through a program change #, a MSB # and and LSB #.  I read that I should do this through changing the global channel.  but I'm not sure how to do this.  Can you guys help?

 

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #2 by daniel_sneed
Not great help, but on my key Blofeld, within a multi program, setting any sound to global midi channel makes Blofeld freeze.
So I don't use global midi channel at all.
Maybe, I will sort this global midi thing out someday.

I don't know about your FC1, but to change multi, you must first set your Blofeld in multi mode manually
Then with your controller, select multi bank by sending : CC0 value 127 (CC0 is bank select, 127 is the number of the multi bank in Blofeld)
Then with your controller send program change ; multi program number by usual program change command (as any other midi device)
To avoid confusion I send all midi messages from controller thru a single midi channel (i.e. midi channel 1), and all parts are set to the same midi channel.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #3 by Peter Ostry
@Burrboe
It looks like a bug in the blofeld.

The "official" sequence for bank/program change is: Bank MSB (CC00) –> Bank LSB (CC32) –> Program Change.
The FC-1 controller (aka TriplePlay) does exactly that and you cannot change this behavior. It works for single sounds on the blofeld. But it does not work for multis. After I send CC 0 127 (blofeld multi bank), the following CC 32 0 breaks the request. If I omit CC32, the multi is selected correctly.

This, for example, works for single sounds: 
CC 0 4
CC 32 0
PC 13

This does not work for multis: 
CC 0 127
CC 32 0
PC 13

Without CC32 it works for multis:
CC 0 127
PC 13

TriplePlay can only send the complete MSB-LSB-PC request. I am afraid that we cannot select any multi programs with the FC-1 at the moment. 

I've sent a bug report to Waldorf.
The manual says that CC32 is not used, but the Blofeld ignores or accepts it as LSB for single sounds, which is perfect. It should do the same for multis.

I tried with the global channel setting but either I did something wrong or it does not help.

 

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #4 by dovgoldman
This isn’t an instant or easy solution to mapping your FC1 to the Blofeld, but it will work extremely well. 

Consider purchasing a BomeBox with Bome Midi Translator Pro (“BMTP”) software. BomeBox is a very compact and well constructed microcontroller (it’s a very small box) with the power to map and translate virtually any midi message into any other. 

You could easily program the BomeBox to trigger on your FC1 messages and spit out the CC#0 127 + PC messages that Blofeld will interpret correctly and switch multi patches. 

I “program” and test in BMTP in a Mac, then load the finished product into the BomeBox, where it reliably executes. 

Once you understand BMTP, almost any Midi project becomes doable relatively easily. 

My BomeBox acts as the “brain” of my complex rig, making my KMI Softstep pedal a super powerful controller for everything. I’ve got Softstep keys doing toggle (tap on, tap off), long press and short press. The BomeBox sets the LED’s and 4 character display on the Softstep EXACTLY the way I want it. 

If you are technical, BomeBox is an incredible solution. If you aren’t willing to learn a bit of programming, it’s not right for you. By the way, Bome’s support is absolutely first rate. 

I’m happy to discuss further if you’d like. 

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago - 2 weeks 6 days ago #5 by Zaphod Betamax
Just set one of my Multi and set all midi channels to Global midi channel.
No problems and I can continue editing on the keyboard's encoders.
No freezing whatsover.

I could try this on all 4 of my Blofelds if required.
Last edit: 2 weeks 6 days ago by Zaphod Betamax.

Please Log in or Create an account to join the conversation.