Blofeld receive MIDI CC only in Multi Mode?

Mehr
1 Jahr 10 Monate her #1 von impulsecoupling
I'm using my Blofeld with Ableton Live. I have integrated it by using Instrument Rack > External Instrument. I mapped the control channels to macro knobs on the instrument rack using the Live mapping mode where I selected the knob on screen, then twisted the physical Blofeld knob for cutoff 1, then cutoff 2, et al.

In program mode I can see my physical Blofeld knob inputs reflected in the knobs on screen, but when moving the on-screen knobs (or automating them in the arrangement) the Blofeld would not respond to the CC messages.

I then tried this in Multi mode and it worked. My on-screen CC changes were received by Blofeld and adjusted the corresponding parameters.

Is this correct? Must I always use Multi mode if I want to receive CC from DAW?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Jahr 10 Monate her #2 von Qwave
I am never using my Blofeld in Multimode here. And no DAW. But receiving MIDI CC works here fine in my Blofeld.

Check if when using the normal playing mode (not multi mode) if the channel you send the MIDI CCs are on the very same MIDI channel set in the Global settings.

In multi mode, the MIDI channels are set in the multi mode parameters and therefor different from the normal playing mode. This is needed, to controll the multi mode parts via separate MIDI channels.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Jahr 10 Monate her #3 von impulsecoupling
For normal/Play Sound mode you can only set the MIDI channel in Global settings. I have done that. It only seems to work one direction though, from Blofeld -> Ableton Live. Blofeld is not receiving CC from Ableton Live unless I put it in Multi Mode.

I will do some more testing and report back.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Jahr 10 Monate her #4 von impulsecoupling
I have made it work in Play/Sound mode. The only thing I did differently was assign the MIDI mapping to Ableton while in Multimode. Ableton recognized the CC differently between Sound and Multi mode. Whichever was captured while in Multi Mode now works with both when I send CC messages from Ableton automation.

Works great! But I'm only 85% sure that's what solved the problem.

it was not the obvious like MIDI channel in Global or having Ctrl Receive set to ON. Had those from beginning.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Jahr 9 Monate her #5 von impulsecoupling
I wanted to report back on this because I think I identified the issue.

When mapping the MIDI CC in Ableton Live, the CC that is output from Play/Sound mode locally on the Blofeld is different than if you use the local control in Multi mode.

Play/Sound mode knob output CC for Cutoff 1 = Channel 1, CC 69

If I use local control knob for Cutoff 1 while in Multi mode = Channel 5(my global MIDI channel) and CC 69.

If I switch back to Play/sound mode after assigning CC in Ableton while in Multi mode, I can control the Cutoff with Ableton over channel 5.

Why are my local controls only sending on channel 1 when in Play/Sound mode?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Jahr 8 Monate her #6 von Zaphod Betamax
cc works fine in performance mode.
easy test for me.
Use Blofeld keys as master to Blofeld slave via midi.
Any controls I change on the master are reflected on the slave.
I make sure that receive cc is enabled and both Blofelds are on same id

Bitte Anmelden oder Registrieren um der Konversation beizutreten.